beta

Govern Production issue

Incident Report for Precisely

Monitoring

A fix has been deployed, and we are monitoring.
Posted Sep 26, 2025 - 09:22 EDT

Update

We have identified the issue impacting Govern environments. Our engineering team is working on and validating the resolution.
Posted Sep 25, 2025 - 15:19 EDT

Investigating

We are aware that some customers are experiencing partial or complete impact in their Govern production environments. Our teams are actively investigating the root cause and working with the highest priority to implement a resolution.
Posted Sep 25, 2025 - 10:17 EDT
This incident affected: Data360 Govern (Data360 Govern US PROD Region, Data360 Govern AU PROD Region, Data360 Govern EU PROD Region, Data360 Govern UK PROD Region, Data360 Govern ASIA PROD Region).