The technical issue which began at 10:58 EST was resolved at 14:32 EST. At this time full functionality has been restored. We will continue to monitor our systems.
Thank you for your patience,
Precisely Emergency Response Team
Posted Mar 05, 2025 - 14:32 EST
Identified
At 10:58am Precisely Data Integrity Suite began experiencing a technical issue which may prevent you from using some features.
The Emergency Response Team is making progress and estimates that all services will be restored in 2 hours.
Thank you for your patience,
Precisely Emergency Response Team
Posted Mar 05, 2025 - 12:55 EST
Investigating
We are working to address a technical issue with the Data Integrity Suite which may prevent you from using some features.
These modules and features are known to be impacted at this time:
- Governance
You will receive an update every 30 minutes until the issue is resolved.
Thank you for your patience,
Precisely Emergency Response Team
Posted Mar 05, 2025 - 11:40 EST
This incident affected: DI Suite (Data Integrity Suite EU, Data Integrity Suite US).