beta
Issue with adding modifying and deleting users in the Workspace
Incident Report for Precisely
Resolved
We had a technical issue with the Data Integrity Suite. This would have impacted the ability to add, modify, and delete users to the DIS workspace. A fix has been implemented and we are monitoring the results.

Thank you for your patience.
Precisely Emergency Response Team
Posted Apr 26, 2023 - 04:00 EDT