beta

Automate Studio Administrator -Email Delivery Issues Affecting Account and User Onboarding

Incident Report for Precisely

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 12:13 EDT

Update

We're currently experiencing an issue due to reaching the SendGrid sending limit. Our team is actively investigating and working on a resolution. We'll provide updates as soon as possible.
Posted Aug 20, 2025 - 11:34 EDT

Investigating

Impact:
We are currently experiencing an issue with the email sending process, which is used in the following flows:
• New Account Creation
• New User Addition

Current Status:
Our team is actively investigating the problem and working on a resolution. During this time, users may not receive expected emails for account and user onboarding.

Next Steps:
Updates will be shared here as we progress.
Posted Aug 20, 2025 - 09:05 EDT
This incident affected: Automate Studio Administrator.