beta
Unable to Add/Remove Users in DI Suite
Incident Report for Precisely
Resolved
This incident has been resolved.
Posted May 29, 2023 - 05:52 EDT
Investigating
There is a technical issue affecting the ability to add, modify, and delete users from the Data Integrity Suite workspace. The issue is being investigated by our team and an update will be sent every 30 minutes until it is resolved.

Thank you for your patience,
Precisely Emergency Response Team
Posted May 29, 2023 - 03:01 EDT
This incident affected: DI Suite (Data Integrity Suite US).