Workaround fixed the issue, we have listed the changes that are needed and will be deployed in the upcoming releases.
Posted Nov 24, 2025 - 15:14 EST
Update
We are continuing to monitor for any further issues.
Posted Nov 20, 2025 - 16:40 EST
Monitoring
We have identified the issue that caused the slowness and worked on a workaround to help the customers in EMEA and APAC Regions. The environments are now responding in a timely manner. We'll be monitoring the environments while the workaround is in place and when we can implement the actual fix.
Posted Nov 20, 2025 - 16:40 EST
Investigating
We are aware of an ongoing service disruption affecting Data360 availability for customers outside the US region. Precisely engineering teams are actively diagnosing the root cause and implementing corrective actions. Updates will be posted here as we make progress. We apologize for the inconvenience caused.
Posted Nov 20, 2025 - 10:09 EST
This incident affected: Data360 Govern (Data360 Govern AU DEV Region, Data360 Govern AU UAT Region, Data360 Govern AU PROD Region, Data360 Govern EU DEV Region, Data360 Govern EU UAT Region, Data360 Govern EU PROD Region, Data360 Govern UK DEV Region, Data360 Govern UK UAT Region, Data360 Govern UK PROD Region, Data360 Govern ASIA DEV Region, Data360 Govern ASIA UAT Region, Data360 Govern ASIA PROD Region).