beta
GeoTAX.com - Outage
Incident Report for Precisely
Resolved
Dear GeoTAX.com customer,

At this time we are seeing full functionality in the system.

We apologize for any inconvenience you encountered during this unscheduled downtime and thank you again for your continued business with Precisely.

This is the final notification regarding this unplanned outage.

Thank you!

The Precisely GeoTAX Team
Posted Apr 07, 2023 - 12:18 EDT
Update
Dear Precisely APIs customer, 

We have found the issue and we are working on it

We will send another update soon.

Thank you for your patience as we continue to work to assure the highest possible level of service.

Thank you!
The Precisely APIs Team
Posted Apr 07, 2023 - 11:13 EDT
Update
We are continuing to investigate this issue.
Posted Apr 07, 2023 - 10:18 EDT
Investigating
Dear GeoTAX.com customer,

We are currently experiencing technical issues which may prevent you from accessing GeoTAX.com.

Our Emergency Response Team is investigating to determine the full scope of the outage and are working to restore the operation of GeoTAX.com. We will send you an update as quickly as possible.

We apologize for any inconvenience and thank you for your continued business with Precisely.

Thank you!

The Precisely GeoTAX Team
Posted Apr 07, 2023 - 09:51 EDT
This incident affected: GeoTAX.