beta

Degraded Performance with Datasources, Connections, Catalog, and Governance UI

Incident Report for Precisely

Resolved

The performance issue which began on Monday 4:33 AM EDT was resolved at Tuesday 2:22 AM EDT. At this time full performance has been restored. We will continue to monitor our systems.

Thank you for your patience,

Precisely Emergency Response Team
Posted Jul 01, 2025 - 06:10 EDT

Monitoring

The technical issue with the Data Integrity Suite that was seen on June 28, is repeating and it may prevent you from using some features.
The following modules and features are known to be impacted at this time:

- Datasources, Connections, Catalog, and Governance UI may intermittently load slowly or fail to load

Currently we are in the process of deploying a fix and you will receive updates as they become available until the issue is resolved.

Thank you for your patience,
Precisely Emergency Response Team
Posted Jun 30, 2025 - 04:33 EDT
This incident affected: DI Suite (Data Integrity Suite US).