beta

Degraded Spatial Analytics functionality

Incident Report for Precisely

Resolved

All services are functioning normally.
Posted Jan 28, 2026 - 17:07 EST

Monitoring

We are seeing recovery in the affected services. The Emergency Response Team is continuing to monitor.
Posted Jan 28, 2026 - 14:21 EST

Investigating

We are working to address a technical issue with the Precisely Data Integrity Suite.

These modules and features are known to be impacted at this time:

Spatial Analytics Location Reports in TrueView/UI
Enrich Data Graph API

You will receive an update every 30 minutes until the issue is resolved.

Thank you for your patience,

Precisely Emergency Response Team
Posted Jan 28, 2026 - 13:54 EST
This incident affected: DI Suite (Data Integrity Suite US).