beta

Data Integrity Suite - Degraded Functionality

Incident Report for Precisely

Resolved

Degraded service performance inside of the Data Integrity Suite in US1 has been resolved.
Posted Aug 24, 2026 - 16:30 EDT

Update

We are continuing to investigate this issue.
Posted Aug 24, 2026 - 16:12 EDT

Investigating

We are working to address a technical issue with the Profiling Suite which may prevent you from using some features.

These modules and features are known to be impacted at this time:

- Quality Rule
- Observer
- Profiling

You will receive an update every 30 minutes until the issue is resolved.

Thank you for your patience,

Precisely Emergency Response Team
Posted Aug 24, 2026 - 16:07 EDT
This incident affected: DI Suite (Data Integrity Suite US).