beta
Outage Notification
Incident Report for Precisely
Resolved
Dear Precisely APIs customer,

We experienced a technical issue starting at 05:00 AM ET. We began seeing recovery at 05:19 AM ET and we are closely monitoring. This impacted our production environment. At this time we see full functionality in the API System.

We apologize for any inconvenience you encountered during this unscheduled downtime and thank you again for your continued business with Precisely.

This is the final notification regarding this unplanned outage.

Thank you!
The Precisely APIs Team
Posted Mar 21, 2022 - 05:20 EDT
Investigating
Dear Precisely APIs customer,

We are currently experiencing technical issues with our production environment which may prevent you from using all features of the Precisely APIs system.

Our Emergency Response Team is investigating to determine the full scope of the outage and will be working to restore the operation of the APIs. We will send you an update as quickly as possible.
We apologize for any inconvenience and thank you for your continued business with Precisely.

Thank you!
The Precisely APIs Team
Posted Mar 21, 2022 - 04:59 EDT
This incident affected: Precisely APIs (Risks, Local Tax, Schools).