beta

DIS - Service Issue: US PROD

Incident Report for Precisely

Resolved

We are seeing a full recovery of services at this time.
Posted Oct 21, 2025 - 09:19 EDT

Monitoring

We are seeing improvements in service availability. We will continue monitoring the situation until full recovery.
Posted Oct 20, 2025 - 18:09 EDT

Update

We're continuing to work on resolving the immediate impact from this incident. We're actively working on recovering our services within the AWS us-east-1 region.
Posted Oct 20, 2025 - 13:42 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 12:11 EDT

Update

Following our earlier notice, we want to share additional details on the service impact.

Cataloging is impacted, including:

- Listing configurations such as asset types and all assets, along with their relationships within the workspace
- Processing events related to the change log
- Scoring functionality
Posted Oct 20, 2025 - 08:30 EDT

Investigating

Dear Data Integrity Suite customer,

We are currently experiencing technical difficulties with our Prod environment due to an ongoing outage caused by issues with AWS DNS in the US-EAST-1 region. As a result, some features of the Data Integrity Suite may be temporarily unavailable.

Our Emergency Response Team is closely monitoring the situation with AWS and working to understand the impact on our services. We will provide updates as soon as more information becomes available.
Posted Oct 20, 2025 - 07:57 EDT
This incident affected: DI Suite (Data Integrity Suite US).