beta

Production Deployment Underway

Incident Report for Precisely

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 09:34 EDT

Monitoring

The production deployment has been successfully completed. We are currently monitoring the environment to ensure services remain stable and perform as expected. We will continue to closely observe the platform and provide further updates if necessary.
Current Status: Monitoring
Posted Jul 15, 2026 - 10:34 EDT

Update

We are continuing to investigate this issue.
Posted Jul 15, 2026 - 10:34 EDT

Investigating

A production deployment is currently underway. Users may experience intermittent service instability while the deployment is being completed. Our team is actively monitoring the environment and will provide updates as necessary.
Posted Jul 15, 2026 - 09:43 EDT
This incident affected: Data360 Govern (Data360 Govern US PROD Region, Data360 Govern AU PROD Region, Data360 Govern EU PROD Region, Data360 Govern UK PROD Region, Data360 Govern ASIA PROD Region).