beta
Outage - Final Notification
Incident Report for Precisely
Resolved
Dear GeoTAX.com customer,

We experienced a technical issue starting at 5:15 AM ET. We began seeing recovery at 5:50 AM ET and we are closely monitoring. This may have impacted your access to GeoTAX.com however at this time we are seeing full functionality in the system.

We apologize for any inconvenience you encountered during this unscheduled downtime and thank you again for your continued business with Precisely.

This is the final notification regarding this unplanned outage.

Thank you!

The Precisely GeoTAX Team
Posted Dec 07, 2020 - 11:05 UTC
Investigating
Dear GeoTAX.com customer,

We are currently experiencing technical issues which may prevent you from accessing GeoTAX.com.

Our Emergency Response Team is investigating to determine the full scope of the outage and are working to restore the operation of GeoTAX.com. We will send you an update as quickly as possible.

We apologize for any inconvenience and thank you for your continued business with Precisely.

Thank you!

The Precisely GeoTAX Team
Posted Dec 07, 2020 - 10:59 UTC
This incident affected: GeoTAX.